Docs: Images Missing
Incident Report for Help Scout
Resolved
Permissions are fixed and we’re closing this out. Your Docs logo, favicon, CSS file and all images should now load as expected. We're really sorry for the trouble today. Here’s a quick summary of what happened: Starting this morning around 8:30 AM EST, we changed a couple of CloudFront encryption settings that unexpectedly touched Docs assets, leading to “Access Denied” errors, which is why images and assets vanished from your Docs sites. We made a mistake, and we learned from it. We’re documenting today’s events along with adding new process checks to make sure this doesn’t happen again.
Posted 5 months ago. Apr 11, 2018 - 11:06 EDT
Update
Quick update: This issue also affects assets that were uploaded using Docs. For example, your favicon, logo, or CSS file. If your CSS file isn't loading, your Docs site probably looks a little disheveled at the moment. It's worth mentioning that no images or assets were deleted or lost, they're just hiding until we can get this sorted.
Posted 5 months ago. Apr 11, 2018 - 10:43 EDT
Update
Unfortunately, the process we're running to restore image permissions is going to take some time to finish. It could be closer to an hour before images are visible again, though we're hoping to speed things up. We'll continue to post updates here as we make progress.
Posted 5 months ago. Apr 11, 2018 - 10:35 EDT
Monitoring
This one is on us. We made some changes to our CloudFront settings, and those changes unexpectedly affected permissions for your Docs images, which is why they've been absent from your articles. We have a fix rolling out now.
Posted 5 months ago. Apr 11, 2018 - 10:14 EDT
Identified
Images uploaded through the Docs editor are currently unavailable. You'll see an "Access Denied" error when viewing the full image URL, in both the Docs editor and in published articles. Sorry about the trouble! We're taking a closer look to see what happened.
Posted 5 months ago. Apr 11, 2018 - 09:57 EDT