Connection Issues
Incident Report for Help Scout
Resolved
And we're back. We reverted an update which did not go to plan, bringing the help desk down for roughly two minutes. Everything is now running smoothly, apologies for the trouble!
Posted Aug 16, 2016 - 12:36 EDT
Identified
Help Scout is currently unavailable. We're on it.
Posted Aug 16, 2016 - 12:32 EDT