Elevated page load times
Incident Report for Help Scout
Postmortem

Between 2:30pm and 3:00pm EST today, Help Scout was experiencing elevated page load times, and roughly 5-10 minutes of downtime.

The cause was an abnormally high load of activity on the queues that process folder counts, Workflows and outgoing email. In an effort to manage the additional load, we increased the number of consumers processing the queues and it had a negative impact on performance in the web application. We backed off the additional consumers and restarted the web servers to get things back to normal.

We don't expect any further issues today. However, the queues are still backed up and it will take a couple of hours (up to 5:35pm EST) to get folder counts, workflows and outgoing emails up-to-date.

There's a lot we can take away from this experience, and there are most definitely some architectural changes that need to be made in order to provide you with a more reliable experience under high load. We're on it!

Posted Dec 18, 2014 - 15:42 EST

Resolved
We've resolved an issue with email processing that affected connectivity to the web app. Service has been restored and conversations are being handled as usual. A full postmortem will follow.
Posted Dec 18, 2014 - 14:57 EST
Identified
We're working to resolve an issue with our email queues. Outbound and inbound replies will still be processed, but may be delayed until the queue clears. We'll have more information shortly.
Posted Dec 18, 2014 - 14:53 EST
Investigating
We're investigating elevated page load times and connection issues. We'll post updates as they're available.
Posted Dec 18, 2014 - 14:35 EST