Degraded Performance
Incident Report for Help Scout
Resolved
Performance is stable across the board. Docs and Help Desk are working as expected. We'll continue to monitor.
Posted Dec 08, 2017 - 10:00 EST
Investigating
We're experiencing some slow downs and are investigating now.
Posted Dec 08, 2017 - 09:51 EST