Docs Sites showing "Page not Found"
Incident Report for Help Scout
Postmortem

Today's brief 5-minute outage for Docs sites was a frustrating one. The issue occurred because we had to make updates to three different services and deploy them at about the same time.

The first two services were updated properly, and the engineer deploying the third service lost his internet connection right when we needed it. He was unavailable for a few minutes, so another engineer went in to deploy the third update. All in all it caused Docs sites to be in limbo for about 5 minutes, displaying a "Page Not Found" error.

It's tough to guarantee this won't happen again, but it was a terrible coincidence to say the least. Sorry for the trouble today, we're full speed ahead now!

Posted Dec 12, 2014 - 16:57 EST

Resolved
Sites are back, postmortem is coming to explain what happened.
Posted Dec 12, 2014 - 15:48 EST
Investigating
Looking into "Page not Found" errors on Docs now
Posted Dec 12, 2014 - 15:43 EST