Slow Page Loads
Incident Report for Help Scout
Resolved
Page load times are back to normal, and all services are up and running smoothly as they should be. We're closing this out. Sorry for the trouble!
Posted 3 months ago. Aug 09, 2017 - 15:14 EDT
Identified
Page load times are returning to normal, though folder counts, search, reports, and inbound/outbound email will be delayed for a few minutes as we monitor all systems to make sure they remain stable.
Posted 3 months ago. Aug 09, 2017 - 15:08 EDT
Investigating
We're looking in to reports of slow page load times across the app. We'll update here when we have more information.
Posted 3 months ago. Aug 09, 2017 - 14:58 EDT