AWS issues causing degraded performance
Incident Report for Help Scout
Resolved
Amazon is close to resolving the root cause of today's performance issues. Help Scout services are starting to return to normal. Email queues are clear, and all assets should be loading. Report exports might still fail on and off, but they should be operational shortly. We're closing this out!
Posted Sep 14, 2017 - 15:56 EDT
Update
It's worth mentioning that some customers may not be able to log in to Help Scout during this event. Some of the display resources for two-factor authentication are currently unavailable.
Posted Sep 14, 2017 - 15:24 EDT
Monitoring
Inbound emails have been processed. New messages will be delivered to your mailboxes over the next few minutes. Performance is still a little rocky. You may notice certain areas of the web app that aren't loading correctly, such as the Apps page, Docs article previews, and customer profiles. We'll continue to provide updates until we're in the clear.
Posted Sep 14, 2017 - 15:21 EDT
Identified
Inbound and outbound email queues are currently backed up due to increased error rates through AWS, our hosting provider. Additionally, Beacon and Docs sites are also affected. This could also impact the viewing and downloading of attachments. We're keeping an eye on things, but it's likely that performance will be up and down until Amazon is able to resolve the root issue.
Posted Sep 14, 2017 - 15:13 EDT