Connection Issues
Incident Report for Help Scout
Postmortem

What happened

This evening between 8:50 and 9:06pm EST, customers experienced sporadic connection issues in the Help Scout web app. An exception caused database connections to leak and rise quickly. Once the Ops team identified the problem, they quickly resolved the exception and restored service to normal.

What we're doing about it

There's still a bit more investigative work to do on this end. We understand what caused the exceptions, but aren't exactly sure why it used up all available database connections. Once we find the problem first thing tomorrow, a fix will be deployed. We don't expect to run into this one again.

Posted Aug 17, 2015 - 22:30 EDT

Resolved
We're in the clear and closing this out. We'll have more to share tomorrow after we dig in and figure out what went wrong. Sorry for the trouble, and thanks for hanging with us!
Posted Aug 17, 2015 - 21:42 EDT
Monitoring
Connection errors have been resolved for the time being, but we're keeping a close eye on this. Sorry for the hassle!
Posted Aug 17, 2015 - 21:28 EDT
Investigating
We're investigating some reports of connection issues and are looking into the issue!
Posted Aug 17, 2015 - 20:57 EDT