Slow Page Loads
Incident Report for Help Scout
Resolved
Help Scout has been stable since 12:20pm EDT and should stay that way. We ran into trouble with new caching infrastructure deployed over a week ago and are making a few changes to prevent these issues moving forward.
Posted Jun 27, 2016 - 13:32 EDT
Identified
We're able to keep page load time around 3-5 seconds (normal is 2 seconds) while we work on a permanent fix. So sorry for the trouble this morning, we'll keep you updated as new information is available.
Posted Jun 27, 2016 - 12:11 EDT
Update
Page load times aren't back to normal yet, but we've gotten them to stabilize around 5 seconds average. We're still working hard to confirm the problem and resolve it as soon as possible.
Posted Jun 27, 2016 - 11:40 EDT
Update
We're still investigating slow page load times in Help Scout, have not identified the root cause yet.
Posted Jun 27, 2016 - 10:40 EDT
Investigating
We're investigating slower than normal page load times in Help Scout, will update when we have more information.
Posted Jun 27, 2016 - 09:38 EDT