Slow Page Loads
Incident Report for Help Scout
Resolved
Slow page load times and performance issues have been resolved. We'll continue to monitor systems closely over the next few hours. Very sorry for the trouble this morning!
Posted Mar 15, 2016 - 11:50 EDT
Monitoring
We've managed to clear up page load sluggishness, performance should be back to normal for the moment. We're still monitoring all systems to make sure they remain stable.
Posted Mar 15, 2016 - 11:34 EDT
Investigating
We're currently investigating reports of connection issues and slow page load times across the app.
Posted Mar 15, 2016 - 11:24 EDT