Slow Page Loads
Incident Report for Help Scout
Postmortem

Yesterday between 10:56am EDT and 11:36am EDT, customers experienced slow page load times across the web app. These performance issues were the result of stalling memcache connections. However, we were unable to identify a root cause with 100% certainty.

We’re working on a few improvements to our caching infrastructure that will help us better understand the problem should this ever happen again.

Posted Jun 07, 2016 - 17:30 EDT

Resolved
This morning around 10:45am EDT, we started seeing slow page load times across the web app. We’re still digging in to the root cause, and will post a follow-up with more information as soon as possible. At roughly 11:30am EDT, all services were back to normal. Very sorry for the trouble today!
Posted Jun 06, 2016 - 12:14 EDT
Monitoring
Page load times are back to normal, inbound and outbound email queues are clear, and all workflows/folder counts are up-to-date. We'll continue to monitor performance for a bit before closing this one out.
Posted Jun 06, 2016 - 11:38 EDT
Update
Page loads are still a little slow across the app. Some customers might see an "Unable to load folder content" error, or an error about losing Internet connection. We'll continue to update here as we have more information to share.
Posted Jun 06, 2016 - 11:32 EDT
Update
We're still investigating slow page loads across the web app. We're working on getting services back to a stable point. Inbound and outbound email will be delayed until we can get this sorted. Additionally, folder views/counts, as well as workflows, will be slow to update until we're in the clear.
Posted Jun 06, 2016 - 11:10 EDT
Investigating
We're currently investigating reports of slow page load times across the app.
Posted Jun 06, 2016 - 11:03 EDT