Slow Page Loads
Incident Report for Help Scout
Postmortem

This morning between 10:05 and 10:30am EST, roughly 17% of page loads in Help Scout were performing more slowly than usual due to a problem with one of our search nodes. The Ops team was able to clear up the issue and get everything back on track within 15 minutes.

We've been hard at work on a project to replace our search infrastructure and plan to start slowly rolling it out this week. The new infrastructure will be much more scalable and tolerant of issues like today's so that customers would not be impacted if it were to happen again.

Posted Feb 24, 2016 - 11:09 EST

Resolved
Page loads are speedy and everything looks good on our end. We're closing this out. Sorry about the trouble today!
Posted Feb 24, 2016 - 10:52 EST
Monitoring
Page load times are back to normal. We'll keep an eye on things for a bit before closing this one out for good.
Posted Feb 24, 2016 - 10:36 EST
Investigating
We're currently investigating reports of connection issues and slow page load times across the app.
Posted Feb 24, 2016 - 10:20 EST