Slowness for customers on FiOS
Incident Report for Help Scout
Resolved
We're closing this out for now, as all Help Scout services are up and running without issue. We'll continue to monitor network performance.
Posted Apr 23, 2015 - 22:00 EDT
Update
All systems are performing normally on our end, and we're not aware of any issues with Help Scout at this time. We're still investigating.
Posted Apr 23, 2015 - 19:22 EDT
Investigating
We're looking into reports of slowness from customers accessing Help Scout on Verizon FiOS.
Posted Apr 23, 2015 - 19:17 EDT