Slow Page Loads
Incident Report for Help Scout
Resolved
All clear! Page load times are back where they should be, we're closing this one out. Sorry for the trouble!
Posted about 1 month ago. Feb 16, 2017 - 13:53 EDT
Monitoring
Page load times are returning to normal, we're keeping an eye on everything and will post a final update when we're in the clear.
Posted about 1 month ago. Feb 16, 2017 - 13:43 EDT
Investigating
We're investigating slower than normal page load times in Help Scout, we'll update when we have more information.
Posted about 1 month ago. Feb 16, 2017 - 13:40 EDT