Slow page loads
Incident Report for Help Scout
Resolved
Slow page load times and performance issues have been resolved. We'll continue to monitor systems closely over the next few hours. Very sorry for the trouble this morning!
Posted Aug 01, 2016 - 11:04 EDT
Monitoring
We've managed to clear up page load sluggishness, performance should be back to normal for the moment. We're still monitoring all systems to make sure they remain stable.
Posted Aug 01, 2016 - 10:55 EDT
Investigating
We're investigating slower than normal page load times in Help Scout, we'll update when we have more information.
Posted Aug 01, 2016 - 10:26 EDT