Connectivity issues
Incident Report for Help Scout
Resolved
Slow page load times and performance issues have been resolved. We'll continue to monitor systems closely over the next few hours. Very sorry for the Saturday morning trouble!
Posted Aug 06, 2016 - 13:54 EDT
Monitoring
We've managed to clear up page load sluggishness, performance should be back to normal for the moment. We're still monitoring all systems to make sure they remain stable.
Posted Aug 06, 2016 - 13:50 EDT
Investigating
We're looking in to slow page load times across the web app. Some customers may also experience a page load error, or time out when attempting to access Help Scout. We'll update as soon as we have more information.
Posted Aug 06, 2016 - 13:28 EDT