Elevated page load times
Incident Report for Help Scout
Resolved
Page load times have returned to normal levels. The issue seems to have been related to a deployment from this morning, which has been reverted. We will continue to monitor this very closely and post any updates here.
Posted Nov 24, 2014 - 12:22 EST
Investigating
We're investigating elevated page loading time for the web app, not sure what's going on yet.
Posted Nov 24, 2014 - 12:17 EST