Slow page loads
Incident Report for Help Scout
Resolved
All clear! Page load times are back where they should be, we're closing this one out.
Posted Aug 16, 2016 - 10:26 EDT
Monitoring
Page load times are returning to normal, we're keeping an eye on all systems.
Posted Aug 16, 2016 - 10:25 EDT
Investigating
We're investigating slower than normal page load times in Help Scout, will update when we have more information.
Posted Aug 16, 2016 - 10:21 EDT