Connections Issues
Incident Report for Help Scout
Resolved
We've been able to resolve the issues with slow page loads across Help Scout, and availability of the Docs platform. We appreciate your patience and welcome you to reach out to Help Scout Support via help@helpscout.com with any follow-up questions.
Posted Apr 22, 2024 - 10:17 EDT
Investigating
We're looking into reports of slow page loads across the app along with Docs sites availability. We'll update here when we have more information.
Posted Apr 22, 2024 - 10:02 EDT
This incident affected: Web App and Docs Sites.